mScriptable

An NDoc Documented Class Library

mScriptable Namespace

Namespace hierarchy

Classes

Class | Description
mScript | mScript is a class that allows you to provide dynamic scripting abilities to your application. You provide an intance of the class with any input values your script will need access to and VBScript code to process the inputs. Values can then be returned from within the script to the caller.


mScript Class

mScript is a class that allows you to provide dynamic scripting abilities to your application. You provide an intance of the class with any input values your script will need access to and VBScript code to process the inputs. Values can then be returned from within the script to the caller.

For a list of all members of this type, see mScript Members.

System.Object
mScript

public class mScript

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: mScriptable

Assembly: mScriptable (in mScriptable.dll)

See Also

mScript Members | mScriptable Namespace


mScript Members

mScript overview

Public Instance Constructors

mScript Constructor Initializes a new instance of the mScript class.

Public Instance Methods

addScriptInput | Sets a variable for input to the script
clearScriptInputs | removes all of the script inputs
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getInputs | returns a hash containing all of the defined script inputs
getScript | Returns the currently defined VBScript
GetType (inherited from Object) |
runScript | Executes the user defined script code using the user supplied script inputs
setScript | Sets the VBScript that will be used by the scriping engine.
setScriptFromFile | Sets the VBScript that will be used by the scripting engine.
setScriptInputs | Allows the user to supply a hash with all of the name value pairs for input to the script
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

mScript Class | mScriptable Namespace


mScript Constructor

Initializes a new instance of the mScript class.

public mScript();

See Also


mScript Methods

The methods of the mScript class are listed below. For a complete list of mScript class members, see the mScript Members topic.

Public Instance Methods

addScriptInput | Sets a variable for input to the script
clearScriptInputs | removes all of the script inputs
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getInputs | returns a hash containing all of the defined script inputs
getScript | Returns the currently defined VBScript
GetType (inherited from Object) |
runScript | Executes the user defined script code using the user supplied script inputs
setScript | Sets the VBScript that will be used by the scriping engine.
setScriptFromFile | Sets the VBScript that will be used by the scripting engine.
setScriptInputs | Allows the user to supply a hash with all of the name value pairs for input to the script
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also


mScript.addScriptInput Method

Sets a variable for input to the script

public void addScriptInput(
String varName,
Object varValue
);

Parameters

varName
a string containing the variable name
varValue
the variable value

See Also


mScript.clearScriptInputs Method

removes all of the script inputs

public void clearScriptInputs();

See Also


mScript.getInputs Method

returns a hash containing all of the defined script inputs

public Hashtable getInputs();

Return Value

the script inputs

See Also


mScript.getScript Method

Returns the currently defined VBScript

public string getScript();

Return Value

The currently defined VBScript

See Also


mScript.runScript Method

Executes the user defined script code using the user supplied script inputs

public Hashtable runScript();

Return Value

A hash containing the script's return values keyed on variable name

See Also


mScript.setScript Method

Sets the VBScript that will be used by the scriping engine.

public void setScript(
String scriptCode
);

Parameters

scriptCode
a string containing the VBScript to use.

See Also


mScript.setScriptFromFile Method

Sets the VBScript that will be used by the scripting engine.

public void setScriptFromFile(
String VBScriptPath
);

Parameters

VBScriptPath
The path to a VBScript file

See Also


mScript.setScriptInputs Method

Allows the user to supply a hash with all of the name value pairs for input to the script

public void setScriptInputs(
Hashtable inputs
);

Parameters

inputs
a table containing name value pairs for variables

See Also


mScriptableHierarchy

An NDoc Documented Class Library

mScriptable Hierarchy

System.Object
mScriptable.mScript

See Also

mScriptable Namespace